
The Dialog Reference Section

This section of the online help for Programmer's File Printer describes all the various dialog 
boxes through which you configure the system and specify your exact requirements.

The dialogs covered are these:

Set attributes for file types
Set attributes for selected files
Edit types shown in list
Printer setup
Select font to use
Set page margins
Set options



Dialog - Set attributes for file types

This dialog lets you choose how listings of files of specific types - for example, all files whose
names end in ".asm" - should appear. You enter it by clicking the Set attributes for file types 
option on the File Menu.

To set up the way files of a given type are to appear

- Select the file type you want from the list of types. If the type is not listed, enter it 
into the edit control, remembering to start it with a dot character.

- Select the formatting options that you want applied to all files of this type.

- Click the DEFINE button to record the settings.

To delete formatting details for a file type

- Select the file type from this list of types.

- Click the DELETE button.

Changes you make in this dialog will, by default, exist only for this session of Programmer's 
File Printer. You can make them permanent at any time by entering this dialog, and clicking 
the SAVE button.



Dialog - Set attributes for selected files

The dialog lets you over-ride the formatting that Programmer's File Printer has decided from 
the file's type. It is also the way you can request that only part of a file should be listed 
rather than the whole.

You enter it by clicking the Set attributes for selected files option from the File Menu, or by 
double-clicking on a file name in the Files selected for printing list.

Any formatting you set here affects only the one file, and only once.

The dialog box contains several separate areas:

List Mode

This area contains buttons that select listing as either text, or as a hex dump. Note that 
some options in other areas are not available if you select a hex dump: you cannot number
lines or wrap long lines, and cannot change the size of a tab stop.

Line Range or Address Range

This area lets you specify whether you want all or part of the file listed. The format will 
change slightly depending on the list mode.

Check the Whole File box to list or dump the whole file. The Start at and End at boxes 
will be unavailable.

If the box is not checked, the selected part of the file is listed. See Listing Range for the 
formats you can use to specify where to start and end the listing. 

List Formatting

This area lets you specify whether you want each page to have a header; whether lines are
numbered; and whether lines that are too wide to fit on a page are truncated or wrapped 
round. You can also set the width of a tab stop to any value between 4 and 16.

Clicking the OK button records the formatting values you've set up for the file.

Clicking the CANCEL button discards any changes you've made.

Clicking the USE DEFAULT button resets the values in the dialog box to those set up for files
of this type.



Dialog - Edit types shown in list

This dialog allows you to configure the file types that appear in the File types shown in list 
area, that in turn controls which file names you'll see from the current directory.

You enter it by clicking the Edit displayed types list option in the File Menu. 

You'll see that the dialog box contains eight edit controls and check boxes, laid out to match 
the appearance of the File types shown in list area. You can change the file type strings in 
any of the boxes as you wish (remember that you must always type a dot in front of the file 
type).

The check boxes beside each of the edit controls affects whether files of that type are shown
in the list or not. You can check these to create the default state that suits you.

Changing default options

From this dialog you can control the default state of the Show all files in directory option of 
the File Menu. If you check the Show files of all types box, the default state will be to 
display the names of all files, ignoring the settings in the File types shown in list area.

By unchecking the Rescan directory automatically box you can suppress the program's 
normal action of rebuilding the Files in directory list whenever you check or uncheck a box 
in the File types shown in list area. You may find this useful if you're working on a floppy 
disk.

The changes you make in this dialog are effective only for the current session. You can make
them permanent at any time by entering the dialog and clicking the SAVE button.



Dialog - Printer setup

This dialog allows you to choose which printer your output is to be sent to, and whether you 
wish files to be printed in reverse page order. You can also run a printer's own setup dialog.

You enter it by clicking the Printer setup option in the Print Menu.

The Printers Available list shows you the names of all the printers configured on your 
system, and the ports they are connected to. You can choose any printer, not just the default
one.

To select a printer you simply click on the name to highlight it. Clicking the OK button will 
record your choice; Programmer's File Printer will use this printer in future sessions until you 
alter your choice.

Clicking the SETUP button runs the printer's own setup dialog. This lets you configure 
printer-specific values such as page orientation and print resolution.

If you printer is a single-sheet device that stacks the output pages the "wrong" way up, you 
can check the Reverse Page Order box. This requests Programmer's File Printer to print 
files from the last one in the Files selected for printing list back the first, and prints each file 
from the last page back the first. The result will be that the pages are stacked in the "right" 
order.

The setting you choose is recorded with the printer, and will automatically be used whenever
you select that device again.



Dialog - Select font to use

This dialog allows you to select the typeface and typesize you want used for your output. 
You enter it by clicking the Select font to use option in the Print Menu.

The Available Fonts list shows you the names of all the fonts available on the currently 
selected printer device. Programmer's File Printer has no word processing capability, and so 
will show you the names of only fixed pitch or non-proportionally spaced fonts: for many 
devices there will be only one font in this class, often Courier.

The Size box lets you choose the type size. The list contains the sizes that the printer driver 
tells Programmer's File Printer are available. You can type other values into the edit control, 
but the printer driver may not give you type of this size.

Programmer's File Printer records the details of the font you select, and automatically uses 
the same face and size the next time you select the same printer.



Dialog - Set page margins

This dialog allows you to select margins on the top, bottom, left and right edges of each 
output page. You can set each margin independently; all are half-an-inch wide. You enter it 
by clicking the Set page margins options in the Print Menu.

The dialog box contains four check boxes, one for each edge of the page. Checking one of 
the boxes causes the relevant margin to be set up.

Margins apply to all printers.

The settings you make are used only for the current session. You can make the values 
permanent at any time by entering the dialog and clicking the SAVE button.



Dialog - Set options

This dialog lets you change some miscellaneous values that affect how Programmer's File 
Printer operates. You enter it by clicking the Set Options option in the Options Menu.

You can:

- Suppress the normal action of removing file names from the Files selected for 
printing list as they are printed.

You may find this useful if you've selected a batch of files that you wish to print 
more than once.

- Suppress the normal action of a form feed character in a text listing, which is to 
start a new page.

You might want to do this to save paper on draft listings.

- Select whether you want Programmer's File Printer to return to the directory you 
were using the last time when you start up.

Click in the check box beside each option to turn it on or off.

The values you set in the dialog apply only to the current session. You can make them 
permanent at any time by starting the dialog and clicking the SAVE button.



The File Menu

The File Menu contains items that let you control how files are to be listed, and to configure 
what file names you wish to see in the Files in directory list.

Most of the options in this menu start dialog boxes that will ask you for more information 
about what you want to do.

Set attributes for file types Sets how files with specific types are to be printed
Set attributes for selected file Sets how specific files are to be printed
Edit displayed types list Sets up the file types shown in the selection boxes
Show all files in directory Shows you all files rather than just those of the selected 

types
Rescan current directory Forces PFP to rebuild its list of the files in the current 

directory
Control Panel Runs the Windows Control Panel
Exit Leaves Programmer's File Printer



Set attributes for file types

This File Menu item lets you specify how you want files with specific file types - for 
example, all files ending in ".c", or in ".asm", to be listed.

Clicking the item starts a dialog that lets you specify a file type, and set up the details of 
how you want the listing to appear.

You can make the settings you've defined permanent, or you can have them discarded when
you leave Programmer's File Printer.



Set attributes for selected file

This File Menu option is available only when you've selected some files for printing, and 
have highlighted their names in the Files selected for printing list.

Clicking the item starts a dialog that allows you to change the way in which these specific 
files are listed. The format settings you select will override the settings implied by their file 
types.

This option is the only way in which you can specify a listing range for the file, which lets you
list some rather than all of it.



Edit displayed types list

This File Menu item lets you set up the contents of the controls in the File types shown in 
list area.

Clicking the item starts a dialog that lets you change what file types are shown in the eight 
boxes, and whether by default those types are to be included in the list of files you see.

This option is not available if you've checked the Show all files in directory option in the File 
Menu.



Show all files in directory

This File Menu item is a toggle, which is either on or off.

When the toggle is on there will be a check mark next to the item in the menu. 
Programmer's File Printer will show you the names of all the files in the current directory in 
the Files in directory list. The File types shown in list area will be grayed out, and the settings
there will be ignored.

When the toggle is off, you will see filenames in the list only if their file types match types in
the File types shown in list area that you have checked.



Rescan current directory

Clicking this option in the File Menu will make Programmer's File Printer re-read the current 
directory immediately and rebuild the list of files you see in the Files in directory list.

If you're working on a floppy disk, you'll probably want to switch off the automatic list 
update that occurs when you select or deselect file types in the File types shown in list area 
and whenever Programmer's File Printer becomes the active application, and use this menu 
item to update the list when you're ready.



Control Panel

This option in the File Menu starts the Windows Control Panel.



Exit

This option in the File Menu terminates Programmer's File Printer. You can also exit the 
program by typing CTRL+X.



Programmer's File Printer Help

This is the online help system for the Programmer's File Printer application, that lets you 
print files such as program source listings.

The help information here should cover all aspects of using the application.

How To Use Programmer's File Printer describes what Programmer's File Printer can do, and 
how you go about using it. Look in this section to get started.

The Command Reference section contains reference material that will remind you what 
each of the menu options do, and when you should use them.

The Dialogs Reference section contains reference material that describes each of the dialog
boxes that you use to set up your exact requirements.

The Distribution and Use section tells you about distributing Programmer's File Printer to 
others, and under what conditions you can use it.

The items in the various sections are interlinked, so you can follow all the information 
relevant to a given topic easily.

Online help does not cover the format of the various items in the Programmer's File Printer 
initialisation file. You'll find this described in full detail in the User Guide.



Distribution and Use

Programmer's File Printer is Copyright © Alan Phillips 1991. It may be freely used by 
individuals, educational institutions and charities; use within commercial organisations is not
permitted without the written agreement of the author.

The program may be stored in software archives or posted to Bulletin Board systems. Apart 
from reasonable media and handling costs, no charge may be levied for its distribution. The 
program should be stored with all the files that accompany its release by the author; 
however archive systems may repackage the files to suit their own storage conventions.

Programmer's File Printer is offered on an as is basis. No guarantee is offered, and none 
should be inferred, as to its functioning, nor to its suitability for any purpose. The author 
accepts no liability for any loss or damage whatsoever in connection with its use.



The Command Reference Section

This section of online help for Programmer's File Printer describes each of the options 
available on the menu bar at the top of the main window. Selecting the main menu item 
name from the list below will take you to the section detailing that item's sub-menu options.

File Menu
Printer Menu
Options Menu



The Options Menu

The options menu lets you set various miscellaneous configuration options.

Set options



Set Options

This Options Menu item starts a dialog that lets you change some miscellaneous values 
that affect how Programmer's File Printer operates. You can:

- Suppress the normal action of removing file names from the Files selected for 
printing list as they are printed.

You may find this useful if you've selected a batch of files that you wish to print 
more than once.

- Suppress the normal action of a form feed character in a text listing, which is to 
start a new page.

You might want to do this to save paper on draft listings.

- Select whether you want Programmer's File Printer to return to the directory you 
were using the last time when you start it up.



How to use Programmer's File Printer

This section of the help file explains what Programmer's File Printer can do, and ways in 
which you can use it. Click the name of the section you're interested in to see further details.

Text listings and hex dumps The two ways of printing files
How PFP can format listingsWhat you can change in the appearance of your listings
Listing or dumping part of a file How to print only the part of a file that you want
Setting up default formatting How to apply default formatting to files of given 

types
Showing files by type How to see only the files you want to work with in the list
Setting up your printer Choosing the output device to use
Choosing the font Choosing the type face and type size to be used
Selecting reverse page order How to print pages from the last to the first
Selecting files to print How to specify what files are to be printed
Deselecting files How to change your mind about listing files
Setting explicit formatting How to override the default formatting for certain files
Starting printing How you actually start to send data to the printer
Cancelling printing How to abandon printing
Setting options Altering some miscellaneous options



Text listings and hex dumps

Programmer's File Printer can print files either as readable text or as hexadecimal dumps, 
depending on your choice.

Normally Programmer's File Printer will list files as text. You can specify that files of particular
types (for example, all .bmp files) are to be printed as hex dumps as explained in Setting 
Default Formatting.

Alternatively, you can specify how you want specific files to be listed and over-ride the 
default values: see Setting Explicit Formatting.

The initialisation file supplied in the distribution set will print .exe, .obj and .lib files as hex 
dumps. All other files will be listed in text format.



Text Listings

When you print a file as readable text it's listed as simply that, with the standard MS-DOS 
end-of-line indication (a carriage-return followed by a line-feed) being taken as end of line. 
Any form feed character causes a new page to be started, although you may suppress this 
to save paper: see Setting Options for details.

Any other control characters are printed as the character "^" followed by the appropriate 
letter. Characters that have bit 7 set are printed as two hexadecimal digits enclosed in "[]" 
brackets.

If a line is too long to fit on the page you can choose to have it truncated at the right margin,
or to have it continue on the next line (and for however many lines it takes to complete it).

Setting Default Formatting tells you how to request a text listing for all files of a given type;   
Setting Explicit Formatting tells you how to do it for individual files.



Hexadecimal Dumps

If you choose to print a file as a hexadecimal dump, Programmer's File Printer will list it in 
lines of 16 bytes. Each line starts with the offset in the file in hexadecimal, followed by 16 
bytes from the file listed as pairs of hexadecimal digits.

On the right of the line, the same 16 bytes are listed as ASCII characters. Here bit 7 of the 
byte is ignored; and any bytes that do not have printable ASCII characters associated with 
them are shown as "." characters.

Setting Default Formatting tells you how to request a hex dump for all files of a given type;    
Setting Explicit Formatting tells you how to do it for individual files.



How Programmer's File Printer Can Format Listings

Programmer's File Printer allows you a lot of flexibility in how you format listings of files, 
enabling you to print them in the way best suited to their use.

You can set the default formatting values to be used when files of a certain type are listed    
as explained in Setting Default Formatting.

You can specify how you want specific files to be listed and over-ride the default values: see 
Setting Explicit Formatting.

You can configure these values:

Page headers

You can choose whether to have headers on each page or not. A header contains the name
of the file; the time it was last updated and the time the printing started; and the page 
number.

Line numbering

You can choose to have each line of the listing numbered on the left, in decimal. You can 
select numbers only for text listings.

Line wrapping

You can choose whether lines that are too long to fit on the page are truncated at the right 
margin, or are wrapped round onto succeeding lines. You can select line wrap only for text 
listings.

Tab width

You can choose where to place the tab stops on a line; you can place them from 4 to 16 
characters apart. You can specify a tab size only for text listings.



Setting Up Default Formatting

Programmer's File Printer allows to associate default formatting information with file types, 
so that for example you can list all files whose names end in ".c" in one way, and all files 
whose names end in ".asm" in another.

You can specify whether a file of a given type is to be listed as text or as a hex dump; and 
whether pages should have headers, whether long lines should be wrapped or truncated; 
whether lines should be numbered; and how wide a tab stop should be. (See How 
Programmer's File Printer Can Format Listings).

The default formatting options don't allow you to specify that only part of a file should be 
listed; this has to be done on a per-file basis as you print them, as explained in Setting 
Explicit Formatting.

The default formatting values for file types are set up using the Set attributes for file types 
option in the File Menu. You can set up values to be used only in this session, or you can 
make them permanent by saving them to Programmer's File Printer's initialisation file.



Selecting Files To Print

In order to tell Programmer's File Printer what files you wish to be printed, you need to move 
to the relevant directories and select the files from within them. (See How to change 
directory).

When you start Programmer's File Printer, the current directory will be the directory you 
were in the last time you used it (provided that this is on a local hard disk or on a network). 
The full name of the directory is always shown at the top of the main window.

The Files in directory list shows you the names of the files in the current directory. If you 
want, you can have this list contain the names of all the files in the directory; or you can 
show only those files whose names end in specified types. See Showing Files By Type for 
how to do this.

To select one or more files from the list to be printed, you must first highlight the names in 
the list box.

- To highlight one file, click once on the name

- To highlight an additional file, hold down CONTROL and click on the name

- To highlight a range of files, click and drag the pointer over the list

- To highlight all the files between two names, click the first, then hold down SHIFT 
and click the second

To un-highlight a file, hold down CONTROL and click on the name.

Once you have a name highlighted in the list the SELECT button will become active. At any 
time you can click on this: the names you've highlighted will be copied to the Files selected 
for printing. The names will appear at the end of the list.

To get multiple copies of a file, simply repeat the process of selecting it as many times as 
you want copies.

A quick way of selecting just one file to be printed is to double-click on its name in the Files 
in directory list.



Deselecting Files

If you've selected a file for printing and later change your mind, you can remove it from the 
list of files selected.

To remove files, you must highlight their names in the Files selected for printing list.

- To highlight one file, click once on the name

- To highlight an additional file, hold down CONTROL and click on the name

- To highlight a range of files, click and drag the pointer over the list

- To highlight all the files between two names, click the first, then hold down SHIFT 
and click the second

To un-highlight a file, hold down CONTROL and click on the name.

Once you've highlighted a file, the UNSELECT button will become active. At any time you 
can click this, and the names of the files you've highlighted will be removed from the list.



Starting Printing

When you've selected the files that you want to be printed (see Selecting files to print) you'll
see that the PRINT button has become active.

Clicking on this button begins printing. A dialog box will appear showing you the details of 
each file as it's printed; the CANCEL button in the dialog box allows you to abandon printing
at any time.

Normally, Programmer's File Printer will print the files in the order that they appear in the 
Files selected for printing list.

If you've specified that printing is to be done in reverse page order (see Selecting Reverse 
Page Order) the files will be listed from the last in the list selected to the first, and each file 
will be printed from the last page to the first.

If you wish, you can specify that file names are removed from the list as they are printed; 
alternatively you can leave the list unchanged if you want to print a whole batch again (see 
Setting Options)



Cancelling Printing

If you decide you want to abandon printing once it's started, simply click the CANCEL button
in the Print Dialog Box.

Printing will be abandoned immediately. Depending on how your printer operates you may 
find that some data that's already been sent to it will still appear.



Setting Options

Programmer's File Printer lets you set a number of options to customise how it operates. You 
can choose to:

- Suppress the normal action of removing file names from the Files selected for 
printing list as they are printed.

You may find this useful if you've selected a batch of files that you wish to print 
more than once.

- Suppress the normal action of a form feed character in a text listing, which is to 
start a new page.

You might want to do this to save paper on draft listings.

To set these options, choose the Set Options item from the Options Menu.



Setting Up Your Printer

Normally Programmer's File Printer will print to the device you've set up as the default 
printer. For most uses, this is exactly what you'll need, and you shouldn't worry about printer
setup.

However, you do have the ability to select other devices, and can run the printer's setup 
dialog from within Programmer's File Printer if you need to configure it.

To choose a different printer, or run the printer's setup, you should choose the Printer Setup 
item from the Printer Menu.

You can select any printer device that has been configured on your system with the Windows
Control Panel. If you choose a non-default printer, Programmer's File Printer will record it in 
its initialisation file, and will use the same device the next time you start it.

The Printer Setup item from the Printer Menu also lets you specify if you want files to be 
printed in reverse page order (see Selecting reverse page order).



Selecting Reverse Page Order

If your printer is a single-sheet printer, it might be that the output pages are stacked in the 
"wrong" order, so that you need to manually shuffle them to get the pages in the correct 
sequence.

Programmer's File Printer allows you to specify which of the printers configured on your 
system do this, by using the Printer Setup option of the Print Menu.

If you select reverse print order for a printer, Programmer's File Printer does two things 
differently:

- It prints the files whose names appear in the Files selected for printing list starting 
with the last, and works up to the first.

- Each file is printed starting from its last page, working through to the first.

The result is that the output stack will contain the pages correctly ordered, starting from 
page one of the first file in the list and ending with the last page of the last file in the list.

If you select this option, you'll notice that the Print Dialog Box shows that text files go 
through a formatting pass before they are printed, as the program works out where each 
page will start. This will slow the process very slightly.



Choosing the Font

Programmer's File Printer allows you to specify the typeface and type size to be used when 
you print files. You can only choose fixed_pitch or non-proportionally spaced fonts - the 
program has no word processing capability.

To specify the details of typeface and size, choose the Select font to use option from the 
Print Menu. This will provide you with a list of what the currently-selected printer supports 
and lets you pick the face and size you want.

If you save the values, Programmer's File Printer will automatically select the specified 
typeface and size the next time you print to this printer.



Setting Page Margins

If you wish to leave blank space on the edges of each page - for binding or punching holes, 
for example - you can select the Set page margins option from the Print Menu to specify 
your requirements.

You can select margins at the top, bottom, left or right of each page independently. Each 
margin is half-an-inch wide. 



Listing or Dumping Part of a File

Normally Programmer's File Printer will list or dump a file in its entirety. However, you can 
specify that an individual files is to be listed or dumped only in part, by specifying a listing 
range for it.

To specify    partial listing, you need to have selected the file for printing so that its name 
appears in the Files selected for printing list (see Selecting Files for Printing).

Next, either double-click the file name in the Files selected for printing list or highlight the 
name and click the Set attributes for selected files item in the File Menu.

This starts a dialog that lets you specify formatting to be applied to this file only. Among the 
things you can specify is whether you want the whole of the file to be listed or dumped, or 
only part of it.

The values you specify apply only to the one listing of the one file. If you've selected the 
same file for printing multiple times, the other occurrences will not use these values. Nor are
the values recorded for the next time you print the file.



Setting Explicit Formatting

Normally, Programmer's File Printer will print a file according to the default formatting details
set up for all files with the same file type (for example, all ".asm" files will print the same 
way). See Setting Up Default Formatting for how to set up this formatting information.

However, you may wish to list some files in a different way to this. Programmer's File Printer 
allows you to over-ride the default formatting for specific files and list them in any way you 
choose. Setting explicit formatting information is also the only way in which you can select a
part of a file to be listed instead of the whole.

To specify    explicit formatting details, you need to have selected the file for printing so that 
its name appears in the Files selected for printing list (see Selecting Files for Printing).

Next, either double-click the file name in the Files selected for printing list or highlight the 
name and click the Set attributes for selected files item in the File Menu.

This starts a dialog that lets you specify formatting to be applied to this file only. You can 
choose between text listing and hex dump and set whether you want page headers and 
other options.

You can also choose to print only a part of the file instead of the whole, by specifying the 
listing range that you require.

The values you specify apply only to the one listing of the one file. If you've selected the 
same file for printing multiple times, the other occurrences will not use these values. Nor are
the values recorded for the next time you print the file.



Showing Files by Type

Initially Programmer's File Printer shows in the Files in directory list the name of every file in 
the current directory. If you have a large number of files you may find it more convenient to 
configure the program to show only files of certain file types - for example, only ".c" and 
".h" files.

The file types shown in the list are selected from up to 8 possibilities from the File types 
shown in list area. Checking the box beside a type will show it in the list.

You can configure the 8 file types available by selecting the Edit displayed types list item 
from the File Menu. This starts a dialog that lets you associate file types with each check 
box, and also set the initial state of each check box.

The Show all types in list item on the File Menu lets you toggle quickly between showing 
only files with types selected from the list, or all files in the current directory.



How To Change Directory

The Directories List shows you the names of all the sub-directories of the current directory, 
and also the names of all the drives on your system.

To move to another directory, scroll the list until you see the name of the one you want to 
change to, and double-click it.

The Files in directory list will automatically be updated whenever you change to a new 
directory.

If you leave Programmers File Printer (see Exiting the program) when the current directory is
one on your local hard disk or on a network, the directory name is recorded in the program's 
initialisation file. The next time you start Programmer's File Printer you'll once again be in 
that directory.



The Printer Menu

The Printer Menu contains items relevant to using a printer - it lets you choose which device 
the program is to use, and to configure it.

The options from this menu start dialogs that will let you specify your exact requirements.

Printer setup Choose which device is to be used
Select font to use Choose the typeface and size
Set page margins Choose the margins to be left around each page



Printer Setup

This Printer Menu option lets you select the printer that you want your output to appear 
on.

Clicking this option starts a dialog, in which you can select any printer configured on your 
system.



Select Font to Use

This Print Menu option lets you select the type face and type size you want used for your 
listings. You can choose only fixed pitch or non-proportionally spaced fonts.

Clicking this options starts a dialog that lets you specify your requirements.



Set Page Margins

This Print Menu option lets you specify whether each output page is to have margins left. 
You can set independent margins on the top, bottom, left and right edges of the page.

Margins are half-an-inch wide.

Clicking the option starts a dialog that lets you specify your requirements.



Listing Range

Normally Programmer's File Printer will list or hex dump the whole of a file. However, if you 
click the Set attributes for selected files option in the file menu, you can specify a listing 
range and list or dump only the part of the file that you're interested in.

If you're printing a file in text mode...

...the listing range is given in terms of line numbers. You can specify, for example, that you 
want to list from lines 25 to 56 inclusive.

The first line of a file is numbered 1.

When you specify a line range in a dialog, you can use the word start to mean the first line
in the file, and end to mean the last line.

If you're producing a hex dump....

...the listing range is given as a pair of file addresses, with the first byte in the file being 
numbered 0.

When you specify addresses in a dialog, you can give them as decimal numbers, or as 
hexadecimal numbers preceded by either x or 0x. You can also use the word start to mean
the start of the file, and end to mean the end of the file.



The Files Selected for Printing List

The list box to the right of the main window that shows you the names of the files that will 
be printed when you click the PRINT button.



The Files in Directory List

The middle of the three list boxes that shows you file names from the current directory. The 
directory name is shown above this list box.



The Directories List

The left-most of the three list boxes that shows the names of sub-directories of the current 
directory, and the names of the drives attached to your system



The File Types Shown in List Area

The set of check boxes to the bottom left of the window. Use this area to control what file 
names appear in the Files in directory list.



The Print Dialog Box

The dialog box that appears when you start printing. It shows you details of the file currently
being processed, and contains a CANCEL button that aborts printing.



The Default Printer

The printer device that you've set as the one to be used by default in the printers section of
the Windows Control Panel.



Fixed-Pitch Fonts

Typefaces in which every character is the same width; essential for when you want to line up
every column in a listing


